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Installing the MPFI Programming Utility 

The windows installer (MPFI_Installer.msi) is the easiest way to install the MPFI Programmer Utility.  It 

will install the application and support files in the proper directory and register the files and create a 

desktop icon.  The name of the installer is MPFI_Installer.msi.  If you received this installer from White 

Oak Audio Design via email, the name has been changed to MPFI_Installer.sav in order to avoid being 

rejected during email transmission by virus checkers that will not let files with the .msi extension be 

emailed.  You will need to rename this file from MPFI_Installer.sav to MPFI_Installer.msi.  It is 

recommended that you save the installer to your Desktop, it can be used later to uninstall the program 

as well.  You can save the .msi to other directory locations as well with no problem. 

Before installing, ensure you do not have a subdirectory on the C: drive that is already named MPFI.  

This is very important as the application will not install properly if this subdirectory already exists 

(very doubtful that this condition exists but please check). 

The installer will create a subdirectory folder on the C: drive at C:\MPFI.  It’s important not to move the 

contents of this application as the program only works out of this specific location. After installation, this 

folder will have 14 files in it and have a folder size of 12,982,466 bytes. 

Before you begin: 

Your PC needs the Microsoft .NET framework loaded on it for this 

program to work properly.  The latest .NET version 3.5 framework is 

available for free download directly from Microsoft. 

Download .NET version 3.5 framework 
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Ensure the Microsoft .NET framework is installed on your PC.  This can be downloaded from the 

following Microsoft website: 

Microsoft .NET version 3.5 Framework 

After you load both pieces of software, you can run the application which is located at: 

“C:\MPFI\MPFI_Programmer.exe” OR just click on the shortcut that is on your desktop (the Oak Leaf 

Icon with ‘MPFI Programmer’ text below it) 

The latest version of these instructions are always downloadable from the White Oak Audio website 

location to guide you in tuning the MPFI. 

MPFI Programming Utility Instructions 

Once you create the desired .HEX file, you can easily and directly program it into the MPFI using the 

PICKit2 based programmer (available from White Oak Audio Design) using the large BLUE "Program 

MPFI" button on the “Row-Columns Settings” tab.  The required firmware OS for the PICKit 2 is v2.32 

and is downloadable from the Microchip link below.  An error will occur if this version is not loaded in 

the programmer.  White Oak Audio preloads this version into the PICKit 2 programmers that it ships. 

The software to independently run the PICKit 2 programmer can be downloaded from this website (it is 

a standalone Microchip GUI program): 
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Microchip PICKit 2 Standalone Programming GUI 

On that page, in the ‘Downloads’ section, click on the “PICKit 2 V2.61 Install” link and follow the 

installation prompts. 

Instructions for operation are also included on this same web page at this link: 

“PICKit 2 Microcontroller Programmer User's Guide” 

Click on it to download the instructions. 

When running the PICkit 2 application, set the VDD PICkit 2 to 5.0V in the mid-right setting box on the 

application screen. 

Use the Auto Import HEX + Write Device button on the lower right of the application screen to point to 

the .HEX file that you created and to program the target MPFI.  The 9V wall wart power supply must be 

powered up, connected to the 9V DC power jack of the MPFI programmer board and the power toggle 

switch on the MPFI Programmer board turned on (the green LED on the programmer board will 

illuminate when the toggle switch bat is in the lower position) 

The PICkit 2 programmer application will provide a success signal when you have programmed the MPFI 

correctly. 

If you have any questions, please feel free to email us at joe@whiteoakaudio.com 

This will open up the main user interface program at the primary tab as shown below.  This application 

provides 200 cell granularity for engine tuning (20 RPM columns by 10 MAP voltage rows) which makes 

it highly flexible. It is simple and intuitive to use, allowing you to spend your time tuning engine 

performance. 

 

The Row-Columns Settings tab  
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Allows you to choose the RPM buckets and MAP voltage buckets.  The RPM range is from 1000 to 9000 

RPM.  The MAP voltage range is from 1.00 to 4.95 volts.  In addition, this tab allows you to set the MAP 

clamp voltage between 0.500 and 4.995 volts using the up-down control in the lower left (the default is 

2.840 volts).  Reasonable default values have been set into this table by design, saving you time when 

starting a new tuning exercise (defaults are as shown above). 

Ensure that the RPM ranges increase in each column from left to right and that no two adjacent columns 

have the same RPM value.  As a general rule, at least 200 RPM should be maintained between adjacent 

column RPM values.  Use the up-down arrows to select the value that you desire. 

Ensure that MAP voltage ranges increase from the top row to bottom row of the table and that no two 

adjacent rows have the same MAP voltage value.  As a general rule, at least 0.15 volts should be 

maintained between adjacent row MAP voltage values.  Use the up-down arrows to select the value that 

you desire. 

After you have decided on the values for RPM, MAP Voltage and MAP Clamp voltage, clicking the ‘Set 

Row-Col Values’ button will lock these choices in on the other 3 tabs.  The ‘Reset Default Row-Col 

Values’ button returns the RPM and MAP Voltage values to the program defaults on the main and 3 

other tuning tabs.  The ‘Set Auto-Tester Values’ button creates a hex file table that is compatible with 

the White Oak Audio Design MPFI auto tester.  This is used for production functional testing purposes 

and allows complete testing of all MPFI functions during final test. 

The ‘Build Hex File’ large GREEN colored button should be clicked after you have properly chosen all the 

values on the other 3 tabs for Injector Duration, vTech solenoid and Anti-Knock Filter. 

The ‘Program MPFI’ large BLUE colored button may be clicked after you have successfully built your .HEX 

file and are ready to program the target MPFI.  If you do not have a target MPFI attached or have not 

defined a valid .HEX file, you will received an Error dialog box explaining the error condition 

encountered.  Correct any errors and attempt again.  When you have successfully programmed the 

target MPFI, you will receive a success dialog box. 

The Injector Duration tab 

Allows you to choose the extra injector dwell time value in milliseconds that is desired for each RPM vs. 

MAP voltage bucket.  The dwell time range is from 0 to 6.3 milliseconds. 

The ‘Clear Injector Values’ button will reset ALL buckets to 0.0 milliseconds.  The ‘Set Diagonal’ button 

automatically sets gradually increasing values as you progress from the upper left of the table (minimum 

values) to the lower right of the table (maximum values).  This is a convenience button to save time by 

providing you approximate starting points.  Use the up-down control arrows to select the values that 

you desire for each cell. 
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Using the FastFill™ feature, you can rapidly populate values in entire rows or columns or multiple rows 

and columns in a few clicks.  Simply select the Rows to Fill and Columns to Fill using the checkboxes and 

scrollbars.  After you have selected the rows and columns you desire to populate, use the up-down 

control to select the Injector Duration desired and then click the ‘FastFill™ Selected Row-Column Values’ 

button.  It’s that simple.  Your rows and columns are filled with your desired value.  You can later edit 

these values using either the individual cell up-down controls or using the FastFill™ feature again. 

The vTech Solenoid tab 

Allows you to choose whether the vTech solenoid is activated or not for each RPM vs. MAP voltage 

bucket.  The choice is either ON or OFF. 

The ‘Same as Anti-Knock’ button will set ALL checkbox buckets to be the same as the Anti-Knock Filter 

tab values.  This is a convenience button to save time. 

The ‘Uncheck All’ and ‘Check All’ buttons automatically clear or set ALL checkboxes.  These are 

convenience buttons to save time. 

The ‘Check Diagonal’ button sets a hard diagonal line from the lower left of the table to the upper right 

of the table with all boxes to the right of this diagonal line checked and those to the left of this line 

unchecked.  This is a convenience button to save time by providing you approximate starting points 

(example shown below).  
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Using the FastFill™ feature, you can rapidly populate values in entire rows or columns or multiple rows 

and columns in a few clicks.  Simply select the Rows to Fill and Columns to Fill using the checkboxes and 

scrollbars.  After you have selected the rows and columns you desire to populate, use the check box 

control to select whether the vTech Solenoid is On or Off as desired and then click the ‘FastFill™ Selected 

Row-Column Values’ button.  It’s that simple.  Your rows and columns are filled with your desired value.  

You can later edit these values using either the individual cell checkbox controls or using the FastFill™ 

feature again. 

The Anti-Knock Filter tab 

Allows you to choose for each RPM vs. MAP voltage bucket whether the Anti-Knock Filter is activated or 

not.  The choice is either ON or OFF. 

The ‘Same as vTech’ button will set ALL checkbox buckets to be the same as the vTech Solenoid tab 

values.  This is a convenience button to save time. 

The ‘Uncheck All’ and ‘Check All’ buttons automatically clear or set ALL checkboxes.  These are 

convenience buttons to save time. 

The ‘Check Diagonal’ button sets a hard diagonal line from the lower left of the table to the upper right 

of the table with all boxes to the right of this diagonal line checked and those to the left of this line 

unchecked.  This is a convenience button to save time by providing you approximate starting points 

(example shown below).  
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Using the FastFill™ feature, you can rapidly populate values in entire rows or columns or multiple rows 

and columns in a few clicks.  Simply select the Rows to Fill and Columns to Fill using the checkboxes and 

scrollbars.  After you have selected the rows and columns you desire to populate, use the check box 

control to select whether the Anti-Knock Filter is On or Off as desired and then click the ‘FastFill™ 

Selected Row-Column Values’ button.  It’s that simple.  Your rows and columns are filled with your 

desired value.  You can later edit these values using either the individual cell checkbox controls or using 

the FastFill™ feature again. 

Once all the desired values have been chosen, return to the main Row-Column Settings tab and click the 

GREEN ‘Build HEX File’ button.  A file save dialog box will open to allow you to choose the path and file 

name for to save the results as.  This path and file name can be up to 62 characters in total length (due 

to limitations within the Assembler and Linker programs).  If you choose a name longer than this, you 

will be warned about this by a dialog box and given the option to change it.  For organization and 

convenience purposes, you should probably create a directory on the C:\ drive at the root level with a 

short but descriptive directory name such as ‘C:\MPFI_Files’ to store your .asm and .HEX files.  The file 

will be saved with an .asm extension in the location you choose and then the assembler will be launched 

and run.  This .asm file is the ‘unassembled calibration’ file that you created.  This .asm file persists after 

the HEX file is built and you can reload it later on to use as a basis for further tuning using the File>Open 

menu option.  Upon successful completion of the Assembler, you will be presented with a success box 

that appears like this: 
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When you click the OK button, the Linker will then run and build the .HEX file.  You will see a small 

command screen open briefly when the Linker is running, it will close upon completion of the linking.  

The .HEX file will have the same base name as you chose for the .asm file above with the exception that 

the file extension will be .HEX instead of .asm. The location of this file will be in the same subdirectory 

that you chose to put the .asm file. 

The .HEX file is the file that you import into the programmer to reprogram your MPFI. 

Other Menu Options 

The File submenu contains menu picks for Open, Save, Save As, Page Setup, Print and Exit.  Save, Save 

As and Page Setup menu picks are not implemented yet and will do nothing if clicked. 

The Open submenu pick will allow you to load a previously saved tuning file.  Each tuning file has a 

White Oak Audio Design unique signature to identify tuning files.  If the application does not recognize 

this signature, it will not open the file and will generate a warning box for the user. 

The Print submenu pick will allow you to print the tuning file to the printer you select in the Print dialog 

box. 

The Exit submenu pick will terminate the application and close all open application windows. 

The Tools submenu contains menu picks for Options.  The Options menu pick is not implemented yet 

and will do nothing if clicked. 

The Help submenu contains menu picks for About.  The About menu pick will open up a dialog box that 

shows the version and copyright information if clicked. 

Known Bugs 
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Restarting the program does not always work consistently on multiple tuning runs.  This will be fixed in 

future versions. 

Revision History 

Revision Date Update comments Author 

A 8/21/2008 Original Release JPK 

B 8/24/2008 Added link to .NET rev 3.5 

framework download.  

Added submenu 

descriptions.  Added 

known bug list.  Other 

minor edits 

JPK 

C 8/29/2008 Updated to reflect 

current bug status for 

revision 0.1.0.4 software.  

Fixed MAP Voltage Clamp 

reset to default of 2.840V 

when Reset Default Row-

Col Values button is 

clicked. 

JPK 

D 8/29/2008 Updated to reflect 

current bug status for 

revision 0.1.0.5 software.  

Fixed all known print 

handler bugs. 

JPK 

E 8/23/2009 Revised instructions to 

reflect use of the MPFI 

Installer instead of 

previous ZIP file 

installation.  Update 
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new FastFill feature.  

Reflects v0.2.0.5 software 

features. 

JPK 
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